Page 1 of 1

Responding to an 'Alarm' Service Call

PostPosted: Wed Dec 14, 2016 5:48
by Zeus
Hello everyone, 8-)

I have a quick question about a service call that I had to respond to a while ago (it was a Mircom panel). The panel was going into 'alarm' once or twice the past few days and the zone was disconnected but still in alarm upon arrival. Let's just say that it is a small building and the panel shows what zone the alarm is in. If all devices have been visually checked and there doesn't seem to be an issue (most devices were heats), what is the best and most effective way when looking for the culprit? Would it be best to clear the panel and play around with each device to see if you get an alarm? Or perhaps wire through each device (same way as 'trouble' signals) and see if the 'alarm' on the panel disappears? Hope to hear from you guys/girls soon.

Thank you,

Zeus (Full CFAA certified but still a bit fresh in the industry)

Re: Responding to an 'Alarm' Service Call

PostPosted: Sat Dec 17, 2016 9:53
by FIRETEK
A "visual" inspection of the automatic detectors might not be sufficient if you're experiencing repeated alarm events from the zone. You may have to drop each device and check for water/corrosion or a loose or pinched wire. In the latter case, the heats closest to a hood could be subject to vibration events that might result in an intermittent contact. Start from there. There's no really easy solution for a conventionally wired fire alarm system, unfortunately. :cry: